www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: [PATCH] configure.ac: Add --with-crypto= instead of many different --with-$backend

Re: [PATCH] configure.ac: Add --with-crypto= instead of many different --with-$backend

From: Peter Stuge <peter_at_stuge.se>
Date: Fri, 11 Nov 2016 00:23:58 +0000

Hi Kamil,

Kamil Dudka wrote:
> This patch seems to break detection of EVP_aes_128_ctr() while building
> against OpenSSL.

Thank you very much for testing, it is much appreciated!

I cleaned up the detection code a bit too much.

The attached fixup patch applies on top of the previous withcrypto
commit and fixes detection for me.

I've also pushed the fixup to my withcrypto branch.

I'm feeling comfortable about --with-crypto now, but it would of
course be great to get even more testing by as many as possible.

If nothing new pops up I'll prepare a single patch for master.

//Peter

_______________________________________________
libssh2-devel https://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel

Received on 2016-11-11

the libssh2 team