www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: Ok, let's talk release again. For real.

Re: Ok, let's talk release again. For real.

From: Peter Stuge <peter_at_stuge.se>
Date: Wed, 4 Mar 2015 15:03:55 +0100

Bert Huijben wrote:
> > Bert Huijben wrote:
> > > I currently use a patch in my own build (that version is attached).
> >
> > Is the new code backwards compatible - ie. works also with older
> > versions of pageant?
..
> The change itself is not relevant, but let me quote r9264's log message:
> [[
> r9264 | simon | 2011-08-13 16:48:36 +0200 (za, 13 aug 2011) | 8 lines
>
> Readjust Pageant's SID check _again_, to make it the union of the
> policies before and after r9178, and hence able to talk to both
> 0.60-like and 0.61-like clients.
>
> I had failed to consider that many pieces of code derived from PuTTY
> would have imported the Pageant client code, so we shouldn't randomly
> stop supporting things just because _we_ aren't using them anymore.
> ]]
>
> The code in libssh2 clearly falls in this category.

Hm, the description above suggests to me that the new code does *not*
work correctly with older versions of pageant?

I guess I have to take a closer look.

//Peter
_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2015-03-04

the libssh2 team