www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: FIPS Compliance.

Re: FIPS Compliance.

From: Daniel Stenberg <daniel_at_haxx.se>
Date: Fri, 25 Jul 2014 09:36:14 +0200 (CEST)

On Fri, 25 Jul 2014, john gloster wrote:

> I wanted to know whether libssh2 1.4.2/1.4.3 are compatible with FIPS
> compliant OpenSSL version *openssl-1.0.0-20* ?
> I compiled libssh2 1.4.3 with this particular version of openssl and i could
> see that my application linking to this libssh crashes.

I only have a vague idea of what FIPS is exactly and what the fips versions of
OpenSSL do, but even a restricted openssl library should not be a reason for
libssh2 to crash (as long as it maintains the API). I'd be interested in a
stack trace of the crash to see what really happened.

  / daniel.haxx.se
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2014-07-25

the libssh2 team