www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: Using libssh2 1.4.3 is creating corrupt files.

Re: Using libssh2 1.4.3 is creating corrupt files.

From: Daniel Stenberg <daniel_at_haxx.se>
Date: Sat, 19 Oct 2013 23:19:54 +0200 (CEST)

On Fri, 18 Oct 2013, Aaron.Stokes_at_us.mahle.com wrote:

> Before using 1.4.3 we were able to send 180MB files through FTP successfully
> with no problems using 1.2.7. Since upgrading to 1.4.3, we have had issues
> of ftp receiving corrupt files. Our solution was to increase the buffer
> size to 10MB solved this problem, but we want to understand why this is
> happening.

Wow, that sounds so... unexpected. You increased the buffer from which size?
And did you check to see if there's a magic limit exactly where the breakage
stopped?

Can you write up a test code and show us that breaks for you? On what
operating system are you using libssh2? Which crypto backend are you using?

How's the RTT to the server, roughly?

Any chance you can try out the latest git version just to make sure the
problem hasn't been fixed already?

-- 
  / daniel.haxx.se
_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2013-10-19

the libssh2 team