www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: [libssh2] #275: ssh agent cannot be used non-blocking

Re: [libssh2] #275: ssh agent cannot be used non-blocking

From: libssh2 Trac <trac_at_libssh2.stuge.se>
Date: Sun, 06 Oct 2013 03:45:40 -0000

#275: ssh agent cannot be used non-blocking
  Reporter: ccutrer | Owner:
      Type: enhancement | Status: new
  Priority: normal | Milestone: 1.4.3
 Component: API | Version: 1.4.2
Resolution: | Keywords:
Blocked By: | Blocks:

Comment (by maxmtl):

 I am not sure if it applies to your case, but I found out that the socket
 used by libssh2 must be set non-blocking, even if the libssh2 API is used
 blocking. I did not find this in the API reference or in the examples.
 (submitting a patch for this is on my list of things to do....). Is your
 socket set to non-blocking?

Ticket URL: <https://trac.libssh2.org/ticket/275#comment:1>
libssh2 <https://trac.libssh2.org/>
C library for writing portable SSH2 clients
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2013-10-06

the libssh2 team