www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: Installing libssh2 on HP-UX

Re: Installing libssh2 on HP-UX

From: Peter Stuge <peter_at_stuge.se>
Date: Thu, 14 Feb 2013 19:04:11 +0100

Hi Wes,

Wes Donze wrote:
> Peter Stuge wrote:
> > Please:
> >
> > 1. git clone git://git.libssh2.org/libssh2.git
> > 2. cd libssh2
> > 3. ./buildconf
> > 4. ./configure --any-parameters-of-yours-here
> > 5. make
> >
> > This should produce the error. Please send us a transcript of this
> > session along with the config.log file.
>
> It now looks like I need to install 'git' to get any diagnostics as
> I do not have that on my hp-ux system.

You can perform the first three steps on any system with the
appropriate tools. I recommend using a Linux system with a rich set
of development tools. On debian or Ubuntu I think you might get them
all by installing the meta-package build-essential. An old
commercial UNIX is not useful for development, so make sure to use a
modern environment where all the useful tools are readily available.

Remember to send a complete transcript of the commands that you run
on the HP-UX system, starting with the command from step 4. In case
the email with full transcript and the config.log file is reject by
the mailing list because of size then please create a ticket on
http://trac.libssh2.org/

Thanks for helping make libssh2 better

//Peter
_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2013-02-14

the libssh2 team