www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: Unable to link with OpenSSL libraries under Cygwin

Re: Unable to link with OpenSSL libraries under Cygwin

From: Alex Rolfe <valistar.chii_at_gmail.com>
Date: Fri, 18 May 2012 02:55:17 -0400

Hello,

Thanks for your help, I got it working.
$ ./configure --prefix=/usr/local/ssh2 --with-libssl-prefix=/usr/local/ssl
--disable-shared
and then I went through and removed -DLIBSSH2_WIN32 from all the makefiles.
So, evidently that was the problem. It looks like the default configure
script for cygwin setups should not include that flag. I don't know
anything about autoconf tools myself, so sorry I can't submit the fix for
that myself. As far as I can tell, its all working fine now.

On Fri, May 18, 2012 at 1:23 AM, Peter Stuge <peter_at_stuge.se> wrote:

> Alex Rolfe wrote:
> > Hello,
> > I tried each of them, and the same problem. When I disable shared, I dont
> > get the " Warning: linker path does not have real file for library
> -lssl."
> > errors. Either way, I get the same undefined reference errors.
>
> Please show full output from the configure and make commands. (I
> don't mean config.log, I mean the output from when you run the
> commands.)
>
>
> //Peter
> _______________________________________________
> libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
>

_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2012-05-18

the libssh2 team