www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: libssh2.pc lacks Requires

Re: libssh2.pc lacks Requires

From: Guenter <lists_at_gknw.net>
Date: Mon, 23 Apr 2012 12:46:14 +0200

Am 23.04.2012 09:48, schrieb Vincent Torri:
> On Mon, Apr 23, 2012 at 1:36 AM, Mikhail Gusarov
> <dottedmag_at_dottedmag.net> wrote:
>>
>> Twas brillig at 01:18:27 23.04.2012 UTC+02 when lists_at_gknw.net did gyre and gimble:
>>
>> >> .private (both for Libs and Requires) is shown when pkg-config is run
>> >> with --static.
>> G> then we should just duplicate it and have both, or?
>>
>> No.
>>
>> If the library is exposed in Libs/Requires, then the client of shared
>> version libssh2 is becoming linked to this library, which is a bad thing
>> (e.g. see http://wiki.mandriva.com/en/Overlinking ).
>
> Right. I post here a discussion i had in the pkg-config list with the
> same problem : http://lists.freedesktop.org/archives/pkg-config/2010-June/000604.html
thanks Vincent.
I did for now just change to 'Requires.private' since only apps which
link statically against libssh2 need the dependencies. Not sure if the
hack what you suggested is needed - pkg-config 0.22 is close to 5 years
out already, and IMO if some uses a version < 0.22 and this fails its
probably a good reminder to the developer to update.
One thing remains though: we do not yet cope with libz dependency.
Shouldnt we have -lz with 'Libs.private:' when build with zlib?

GŁn.

_______________________________________________
libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2012-04-23

the libssh2 team