www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples | github

Archive Index This month's Index

Subject: Re: libssh2-1.2.8-20110111 issue

Re: libssh2-1.2.8-20110111 issue

From: Guenter <lists_at_gknw.net>
Date: Thu, 13 Jan 2011 03:19:55 +0100

Am 12.01.2011 06:57, schrieb zl liu:
> The testing of libssh2-1.2.8-20110111£¬
> Compiled with visual c++ 6.0 and has following errors£º
> libssh2-1.2.8-20110111\src\session.c(359) : error C2065: 'socklen_t' :
> undeclared identifier
we dont support VC 6.0 without PSDK; if you really want to compile with
12+ year old headers then you need to add a line
typedef int socklen_t;
to your winsock2.h header.


libssh2-devel http://cool.haxx.se/cgi-bin/mailman/listinfo/libssh2-devel
Received on 2011-01-13

the libssh2 team