www.libssh2.org | Daily snapshots | Mailing list archive | Docs | Examples

Archive Index This month's Index

Subject: Re: [libssh2] automake and friends

Re: [libssh2] automake and friends

From: Heiko Jansen <jansen_at_hbz-nrw.de>
Date: Tue, 21 Nov 2006 10:36:21 +0100

Hi Daniel.

Am Dienstag, 21. November 2006 00:21 schrieb Daniel Stenberg
<daniel_at_haxx.se> [Re: [libssh2] automake and friends]:

> Right, and it seemed that all the symbols you got problems with
> are using "inline". So I just now added a proper check for inline
> in configure.
> Please try again!

That did not resolve the problem, either.
In the meantime I have found a solution to the problem but I´m unsure
if it has any undesired side effects: simply adding
-- snip --
LIBSSH2_API int libssh2_packet_x11_open(LIBSSH2_SESSION *session, unsigned char *data, unsigned long datalen);
LIBSSH2_API int libssh2_poll_channel_write(LIBSSH2_CHANNEL *channel);
LIBSSH2_API int libssh2_packet_queue_listener(LIBSSH2_SESSION *session, unsigned char *data, unsigned long datalen);
LIBSSH2_API int libssh2_poll_listener_queued(LIBSSH2_LISTENER *listener);
-- / snip --
to ~/include/libssh2.h did the trick.

ssh2_sample.c still wouldn´t compile because the symbol "ceil" was
reported missing - but that was rather easily fixed by adding "-lm" to
the flags.

Another minor problem (which I recently reported to the bug tracker):
INSTALL mentions "--with-zlib" while configure.in uses "libz".

Heiko

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
libssh2-devel mailing list
libssh2-devel_at_lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/libssh2-devel
Received on 2006-11-21

the libssh2 team